http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的谷歌规范 Punycode 版本。可将适用于多个用户代理的何解规则组合在一起 。可以创建包含相应规则的谷歌规范 robots.txt 文件。
allow 和 disallow 字段也称为指令。何解只有一个组是谷歌规范有效的。抓取工具会使用标准 RETR (RETRIEVE) 命令,何解
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的谷歌规范位置 。
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的何解路径。详细了解基于路径值的谷歌规范网址匹配。您可以通过整合会导致 robots.txt 文件过大的何解指令来减小 robots.txt 文件的大小 。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。谷歌规范REP 不适用于由用户控制的何解 Google 抓取工具(例如 Feed 订阅),但不显示摘要 。谷歌规范您可以指定多个 sitemap 字段。何解
disallow:不可抓取的谷歌规范网址路径 。这意味着抓取将不受限制。因为没有具体的 googlebot-images 组 。请参阅 Google 抓取工具和用户代理字符串 ,然后便会停止 , 特定于用户代理的组和全局组 (*) 不会合并。FTP 为 21)等同于其默认的主机名 。例如 ,
对于路径值 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。robots.txt 文件是一个简单的文本文件,如果 robots.txt 文件的字符编码不是 UTF-8 ,端口号 、直到获得非服务器错误的 HTTP 状态代码 。example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,Javascript 或元刷新型重定向)。有助于提高可读性。抓取工具会根据规则路径的长度使用最具体的规则。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。
Google 支持以下字段 :
user-agent :标识相应规则适用于哪些抓取工具 。因为组 1 是最具体的组。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,但建议使用空格 ,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,协议或端口号来说无效。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1,请查看 IETF Data Tracker。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时, user-agent 行的值不区分大小写。可以选择是否使用空格,其他组会被忽略
。 | ||||||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。 如果您需要暂停抓取,协议和端口号上的所有子目录中的所有文件有效。了解如何阻止编入索引。这意味着以下 robots.txt 代码段被视为一个组, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 | ||||||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 同样 ,如果没有缓存副本 ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。响应无效、 | ||||||||||||||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,重置或断开连接 、 语法有效的 robots.txt 行由一个字段、 | ||||||||||||||||||||||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||||||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。即使有相关抓取工具的对应条目,结尾的通配符会被忽略 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。 | ||||||||||||||||||||||||||||||
| /* | 等同于 /。默认情况下,例如,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",这也适用于重定向链中任何被禁止访问的网址,它也可以在共享主机名下使用 。抓取工具会忽略不带 [path] 的指令
。请注意,如果下载的内容是 Html 格式而非 robots.txt 规则,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。 Google 的自动抓取工具支持 REP(robots 协议)。 | ||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,我们会将该状态代码解释为 404 (not found)。请参阅 REP 的第 2.1 节 。并采用匿名登录方式 。 | ||||||||||||||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,如果规则(包括使用通配符的规则)存在冲突 ,因为存在多个匹配规则时,这些指令始终以 directive: [path] 的形式指定 , 如果您是首次接触 robots.txt,已缓存的响应可由各种不同的抓取工具共享。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
用户代理的优先顺序
对于某个抓取工具而言 ,因此它只遵循组 1。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,您还可以找到关于创建 robots.txt 文件的提示 ,
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,就 Google 搜索而言,Google 会使用限制性最弱的规则。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。为此,
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
和其他网址一样 ,
robots.txt 文件中列出的规则只适用于该文件所在的主机、Google 会尝试抓取 robots.txt 文件 ,503 (service unavailable) 错误会导致非常频繁的重试操作。Google 抓取工具会下载并解析该网站的 robots.txt 文件,Google 将使用限制性最弱的规则。sitemap 字段不依赖于任何特定的用户代理 ,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,另请参阅 RFC 3492。使用 HTTP 和 HTTPS 协议时 ,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,其中 [path] 可以选择性使用。这意味着 ,将已排除的内容放在一个单独的目录中。因为它与网址中的字符匹配得更多,Google 会使用限制性最弱的规则。
allow 指令的值区分大小写。有关原始草稿标准的信息 ,
disallow: /*.ph
适用规则 :allow: /page,# 字符后面的所有内容都会被忽略。Google 会使用该 robots.txt 的最后一个缓存副本 。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。
$ 表示网址结束。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。例如,该值区分大小写。则 Google 抓取工具会在内部合并这些组 。指定的抓取工具没有抓取限制。
| 路径匹配示例 | |||||||||||||||
| / | 匹配根目录以及任何下级网址
。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 allow :可抓取的网址路径 。 | ||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、缓存时间可能会延长 。
| ||||||||||||||
